Tuesday, 9 July 2013

Setting Web Proxy MikroTIK


Kebanyakan proxy merupakan web proxy, yang mengizinkan penggunanya untuk mengakses konten di internet.
Server proxy memiliki banyak jenis sesuai dengan tujuanya, termasuk:
Untuk menjaga mesin di balik anonim (terutama untuk security).[1]meningkatkan akses ke sumber (menggunakan caching). 
Web proxy biasanya digunakan untuk cache halaman internet dari server web. [2]menerapkan aturan akses terhadap internet atau isinya, e.g. to block undesired sites.
Untuk penggunaan log / audit, yaitu untuk menyediakan karyawan perusahaan pelaporan penggunaan Internet.
Untuk melewati kontrol keamanan/ parental. memindai perpindahan konten bila terdapat malware sebelumya.
Untuk memindai konten outbound, misalnya untuk perlindungan data dari kebocoran.
Untuk menghindari pembatasan regional.(Wikipedia)
Dalam artikel ini akan sedikit kita bahasa tentang bagaimana membuat/ setting sebuah web proxy di Mikrotik.  Ada beberapa lavel yang harus kita kerjakan dan ada 2 cara yang bisa kita lakukan ketika bekerja dengan MikroTIK, yaitu :

  1. Melalui koneksi Console/CLI
  2. Melalui Software WinBox dan mengakses MikroTik RouterOS secara SSH.

Kali ini saya akan mencoba share untuk yang melalui Console/CLI, entah CLInya komputer MikroTik RouterOS maupun yang telah di-SSH melalui winbox. Ada 3 tahapan utama yang harus dilakukan :

1. Konfigurasi Web Proxyy

[admin@Mikrotik] > ip web-proxy
[admin@Mikrotik] ip web-proxy> set enabled=yes ==> untuk membuat ip web proxy aktif
[admin@Mikrotik] ip web-proxy> set src-address=0.0.0.0 ==> address yang akan digunakan untuk koneksi ke parent proxy
[admin@Mikrotik] ip web-proxy> set port=8080 ==> membuat port untuk web proxy [admin@BlueSoft] ip web-proxy> set hostname= admin [bisa diganti] ==> hostname dari web proxy
[admin@Mikrotik] ip web-proxy> set transparent-proxy=yes ==> meng-enable-kan proxy secara transparant
[admin@Mikrotik] ip web-proxy> set parent-proxy=0.0.0.0:0 ==> address dari parent proxy
[admin@Mikrotik] ip web-proxy> set cache-administrator=blue.sofware@yahoo.com (isi dengan alamat email)     ==> email administrator/maintainer, apabila proxy error, status akan dikirim ke email ini.
[admin@Mikrotik] ip web-proxy> set max-object-size=4096KiB ==> ukuran maksimal file yang akan disimpan sebagai cache (4096KiB adalah default )
[admin@Mikrotik] ip web-proxy> set cache-drive=system ==> posisi dimana cache akan disimpan
[admin@Mikrotik] ip web-proxy> set max-cache-size=unlimited ==> ukuran maksimal hardisk yang akan dipakai sebagai penyimpan file cache
[admin@Mikrotik] ip web-proxy> set max-ram-cache-size=unlimited ==> maksimal ram yang digunakan untuk menyimpan cache

2. Konfigurasi NAT-Redirect

Setelah setting dari web proxy selesai, sekarang kita mencoba membelokkan traffic http ke arah web proxy atau dengan kata lain akan memaksa akses yang keluar untuk memasuki web proxy kita dahulu. Port yang perlu dibelokkan biasanya 80,3128 dan 8080. Konfigurasinya :
[admin@MikroTIK] ip web-proxy> /ip firewall nat add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=8080 ==> akan meredirect port 80 ke 8080 (portnya web proxy)
[admin@MikroTIK] ip web-proxy> /ip firewall nat add chain=dstnat protocol=tcp dst-port=3128 action=redirect to-ports=8080 ==> akan meredirect port 3128 ke 8080 (portnya web proxy)
[admin@MikroTIK] ip web-proxy> /ip firewall nat add chain=dstnat protocol=tcp dst-port=8080 action=redirect to-ports=8080 ==> akan meredirect port 3128 ke 8080 (portnya web proxy)

3. Blok Situs
Dari tahap di atas telah di lakukan proses settingan web-proxy kita dah sudah bisa digunakan dan berikutnya Bagaimana proses konfigurasi untuk blok sebuah situs yang menurut kita layak untuk di blok, biasanya situs situs yang berbau sarah dan saruh 

contohnya sbb:
[admin@MikroTIK] ip web-proxy> access add url=blue.com method=any action=deny

Dari CLI diatas digunakan untuk mengblokir situ blue.com, jika kita akses lewat web brose dan menuliskan alamat situs tersebut akan ada informasi bahwa situs tersebut tidak bisa dibuka silakan hubungi admin, kalau masih bisa terbuka berarti konfigurasi kita ada yang salah, silakan di-trace di mana kesalahan kita.


Selamat Mencoba :-)

2 comments:

  • Anonymous says:
    12 July 2013 at 00:28

    ini yang ane cari thanks gan..

  • IBas Koro says:
    14 July 2013 at 06:20

    semoga bermanfaat, thanks atas kunjungannya ya..

Post a Comment